Running Acrosync with SSH chroot

I am about to go insane here... I have a SSH chroot set up that I can log into and run rsync without any directory specification (ie, it is in the path)... and it runs fine from a shell... as soon as I run it from Acrosync I get:

"bash: rsync: command not found"

I turn off the jail and things run... but I NEED the jail for security.

I have no idea what else to try... I'd force a path in Acrosync if that were an option, but it doesn't look like it is.


  • I think you just need to set PATH in ~/.ssh/environment in order for the ssh daemon to find the rsync executable.
  • Ok, that got me on the right path (no pun intended)...

    Also need to enable "PermitUserEnvironment" in sshd.conf as well in order for it to work.

Sign In or Register to comment.