I am searching for a reliable way to synchronize large (~1 TB) file stores with the Box cloud service.

A simple copy (which the web client can handle) is inadequate for this task, as you have the constant problem of active files within the store changing before the copy completes.  (It'll take more than a minute to send 1TB over even the fastest internet connection!)

Box has a client for this ... unfortunately, it is not compatible with Server 2012, where the files reside. Hence, my search for a solution.

I'm a Linux guy, so I immediately thought of Rsync.  I figured if I could get Rsync to use the cloud service as a destination, that I could setup an Rsync task for each required folder, and I'd be done.

And that half of the problem appears to be solved. The service "couchdrop" does indeed allow Rsync transfers to a handful of clould providers ... and Box is one of them.

So all I need now is a Windows Rsync implementation. And I was actually shocked at the slim pickings here! This appears to be the best and most straightforward solution, however I cannot for the life of me get the Acrosync dialog to successfully connect to the couchdrop server at:

From a Linux machine, I can connect to my account there just fine from the command line, so I know that my credentials, etc. are valid and correct.  The syntax is as follows:

rsync -a -e ssh filename</

I'm not changing any defaults (ssh=yes, public key=no, everything else blank) and perhaps that's the problem, but putting "" in the server field, and "username" (actually my username) in the username field, along with my password, only sends the connection dialog into limbo for 10 minutes until it finally times out with:

"The Rsync channel has been blocked for more than 600 seconds"  

Has anybody ever gotten these two to play together?  It seems like an elegant and perfect solution to what I imagine isn't that rare of a problem.  Any help would be appreciated before I reluctantly descend into the world of "fake" Linux shells that exist so that Rsync can be faked from the Windows command line.  Some of those are even free, but I'd really much rather use Acrosync if at all possible!



  • I tried myself, and yes, it got stuck without any progress until it timed out eventually.  I need to run more testing to figure out the cause of the issue.
Sign In or Register to comment.