How to enter SSH private key?

edited October 2014 in Acrosync for Windows
Hi,

I just found Acrosync and tried to use the beta. However, I got stuck with entering (copy-paste) the SSH private key to the text area that opens once the "public key"-checkbox has been checked and I click "Remote directory" to enter the remote directory.

The error messages says:

"Authentication by public key failed: unable to extract public key from private key file: Unable to open private key file"

Which is kind of weird since the UI asked me to enter the private key content, not the its file name. So my question is, which format the private key should be? OpenSSH RSA key? Putty key format? Something else? I tried both Putty and OpenSSH format without success.

I am running Win 8.1 64 bit if that matters.

Jarno



Comments

  • This is a regression bug caused by a build change.

    I uploaded a new build 393 which should fix the bug.  Just reinstall Acrosync from www.acrosync.com.

    The key should be in OpenSSH format.  Both DSA and RSA are supported.

  • I gave up Acrosync last time and returned now after 4 years decided to give it a 2nd try. And surprisingly it still fails on the very same error. My key is OpenSHH private key and I paste it with the '-----BEGIN OPENSSH PRIVATE KEY-----' tags.

    I have generated the key by converting a working Putty private key with puttygen Key-> Conversions -> Export OpenSSH (Force new file format)
  • Exactly the same problem for me...
  • The tag should be '-----BEGIN RSA PRIVATE KEY-----' or '-----BEGIN DSA PRIVATE KEY-----'.  If you select 'Export OpenSSH key' you will get either of these two tags.


    '-----BEGIN OPENSSH PRIVATE KEY-----' is created by 'Export OpenSSH key (for new file format)', which isn't supported.

  • Magic, it works ;-)
Sign In or Register to comment.