Run as a Service - No AutoUpload?


I think this is a great program, and we are converting over our nas over to a windows file server but still need to sync to another synology NAS and this is perfect.

We are a development company and when we cut a release, TFS uploads to our file server, which is then synced offsite to our cloud hosted environment to a NAS.

We need our uploads to happen every 5 minutes, with rsync on the NAS we use to have an hourly task that would rsync every release and a 5 minute that would sync anything with the name of "Beta"

I thought I had found the holy grail, and was very impressed with the application that detects changed files and auto uploads. This was perfect!!

However, how do I get this to work when running it as a service?

At the moment, I have created 12 profiles that sync every 5 minutes, I would use task scheduler, but I am also disappointed that when running via command line/task scheduler, it does not output to any log files.


  • If you use Windows Task Scheduler, I think you just need to create one profile that runs every 5 minutes.  You must assign a name to the profile.  If you don't assign it a name, what is being displayed in the profile tab is just the last component of the local directory.

    When you attempt to run a profile without a name via command line, Acrosync fails silently.  This has been fixed in build 566.  If you download the latest version from our website you'll get this fix.
  • gchen, I used the service and created a profile every 5 minutes with different names.

    This worked for awhile then it got a socket error after about 12 hours of working fine, I suspect the NAS on the other end was busy and hasn't worked since and then each job reported a socket error.

    2017/05/02 01:45:35 SOCKET_CONNECT Failed to connect to '': connection timeout 
    2017/05/02 01:50:50 SOCKET_CONNECT Failed to create the socket: 10055
    2017/05/02 01:55:02 SOCKET_CONNECT Failed to create the socket: 10055
    2017/05/02 02:00:16 SOCKET_CONNECT Failed to create the socket: 10055

    Interesting it created new logs every time it failed?

    I already had a method using the acrosync service. Looks like this is not a good method.

    I wanted to do task scheduler, but there is no log? how do I output a log when using command line, task scheduler?

  • You can redirect the stdout to a file:

    AcrosyncClient64.exe -p profile > log.txt

  • gchen, have you actually tested this yourself???

    Just running from a command line simply launches the program go back to prompt (the program is running in the background).

    There is no output on the console/command line and it does not show any information.

    I am a bit disappointed, the more I try and use this program, it just doesn't seem like it will work.

    I now can't even reliably run it from the program under a user session with out connection issues stopping it from working.
  • Well I finally got output, but only after the program messed around for 2 minutes (not really sure what its doing for those first few minutes) Would be nice that when the program is launched it instantly rights something to know the program has started.
  • If you redirect the stdout to a file in a DOS prompt window, it should work and I've tested it myself.

    However, if you don't redirect the stdout to a file, it won't give you the log output in the DOS prompt window -- this is due to a bug introduced when we upgraded the compiler to VS 2015.  We've fixed this bug in the latest build available here:

            32 bit:

            64 bit:

    Let me know if this fix doesn't work for you.

Sign In or Register to comment.