wont bakcup all photos after an iphone reset

Hey guys, 
I LOVE photobackup and have it on all of mine and my wife's IOS devices, we use it to backup to a linux box at home and it has ran really well until yesterday. 
I had to do a full reset/restore of my iphone because of a issue I was having with visual voicemail. When I got my photo backup set up again it warned me that the directory that I wanted to use already has a .photobackup file and to delete it to use this directory. 
I deleted it, but now when I try to do a full backup again (i have always just selected the "backup all photos" option) it starts indexing the photos (about 6K of them) but the app crashes around 1024 each time.

I would like to get this backup working again. 
most of my photos are already backed up. I am wondering if I can fake/recreate the .photobackup file so that I can get these going again or what you guys recommend. 
I am running the latest version of IOS and the latest version of photobackup. 



  • You can create a minimum .photobackup file like this:

    p.p1 {margin: 0.0px 0.0px 0.0px 0.0px; font: 11.0px Menlo; color: #000000; background-color: #ffffff}
    span.s1 {font-variant-ligatures: no-common-ligatures}

    ID: D329F7B5-7019-419F-97FB-80BA42BAF9F2

    version: original

    time: 1417402986

    When PhotoBackup complains about the device being different, replace the id with the one shown in the error message.

    Indexing will limited to photos newer than the time specified in the time line.  So you just need to change it to the timestamp of the last photo backed up before.

    If you send me the crash log, I might be able to figure out why it crashes (either out of memory or a bug).  Here is how to retrieve the crash log:

  • I have played with a few settings, If I select some pictures to backup manually they work just fine (it always has). 
    I created a fake .photobackup and pasted thw rong ID in it. when the phone starts backing up it stops and tells me the ID issue. so I updated the ID with it and then it starts the backup. I also changed the time: to the last backup for me (feb 18th.) ( it looks like you are using epoc time so my time stamp is 1487463955, also I changed the file to have the right permissions (as far as i can see.

    -r--r--r-- 1 uploader uploader 1.7M Mar  9 17:59 IMG_4089.JPG
    -r--r--r-- 1 uploader uploader 1.8M Mar  9 17:59 IMG_4090.JPG
    -rw-r--r-- 1 uploader uploader   76 Mar 13 11:44 .photobackup

    cat .photobackup
    ID: 8B3A3155-A5D7-48F0-87A1-1C951515ED7A
    version: original
    time: 1487438755

    On my old backups I was using the time machine style, on the new one I would like to be able to just directly back them up. but at this point that is minor. 
  • It looks like an iOS bug from the crash log (thread 9 is all iOS code).
  • Hey I tried it today and it is working so far. it is re uploading all of my old pictures from the beginning of time but I wont complain... 
    One question I have is on the upload structure. why do we get this??
    Is there an option to just upload the files so that I can just have 1 directory with all of the pictures in there instead of into thses *APPLE files?
    Ps let me know where to send a donation! 
  • That is how iOS organizes the photo and video directories internally.  Remember the filenames are in the format of IMG_xxxx so you can have at most 9999 photos under the same directory.  If you upload all photos and videos to the same directory there is a change some old photos will be overwritten eventually.

    We don't accept donations (we make money from other software) but if you can leave a review in the App Store that would be greatly appreciated.

  • Sorry for all of the comments on this. It uploaded for a while then it gave me an error " Error reading asset at 107APPLE/IMG7044.3gp"
    I tried it again and it still gave the same error, I went into my photos and tried to delete the photo that should be the one causing the issue then it took several attempts to get it to start uploading again. (it kept crashing during indexing again) but it is uploading now. Kinda weird. Sure appreciate the app! 
  • Wahoo successful backup complete! Thank you for all of the help and I just left a review. Thanks!!! 
  • I don't think *.3gp is a native iOS photo or video file, isn't it?  Did you import that file from a camera?

    I'll look into the indexing issue.  Thank you for the review!

  • I also get these crashes during indexing. I don't have a Mac to upload logs, but if there's any other way I can debug, let me know.

    Running the program several times will eventually progress past those files and make the index, allowing me to proceed.
  • I think iOS killed PhotoBackup because of memory constraints.  Maybe PhotoBackup should only attempt to index and upload a limited number of photos each time.
  • When we have issues with memory constraints on big file systems (in linux) instead of doing a plain rsync (which bathes all of the files) we do a find command to an rsync. This avoids the memory overload because it will then rsync one file at a time instead of batching them all together. IDK if this is valuable or not? 
Sign In or Register to comment.